Error: Incompatible Library version

I’m trying to use Ruby on an Apple running High Sierra. I get this error:

1: from /usr/local/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require' /usr/local/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require’: incompatible library version - /Users/mlevin/.rvm/gems/ruby-2.5.0/gems/sqlite3-1.3.10/lib/sqlite3/sqlite3_native.bundle (LoadError)

how to fix this?

Try to remove the systemwide sqlite3 gem by doing:

gem uninstall sqlite3

and then reinstall it with either

gem install sqlite3

or if using a Gemfile and Bundler use

bundle install

so I did
gem uninstall sqlite3
gem install sqlite3

and it installed sqlite3-1.3.13 and I still get the same error :frowning:
How to tell what version of what is incompatible with what? I’m not sure what the right state is supposed to be. And, what is the Gemfile/Bundler - would that help? What directory should I be looking for this Gemfile in?

thank you!!